Релиз VLC 1.0.5. Планы по развитию VLC в будущем

01.02.2010 01:10

Вышел корректирующий релиз видеопроигрывателя VLC 1.0.5, в котором исправлены ошибки, обновлены файлы переводов и проведена оптимизация производительности. Особенно заметное увеличение скорости работы наблюдается в версии для платформы Windows: были обновлены кодеки и осуществлен переход на сборку при помощи gcc 4.4.2. С момента выхода прошлой версии 1.0.3 с сайта проекта было загружено более 51 млн. копий VLC.

Кроме того, рассказано о некоторых планах на будущее, например, для поддержки акселерации проигрывания видео будет использоваться VAAPI (libVA), API развиваемый в качестве преемника XvMC. В настоящий момент VAAPI поддерживает задействование GPU-акселерации для видеокарт Intel и S3 Chrome, акселерация для карт NVidia будет производиться через специальный враппер VDPAU-VAAPI, а для карт AMD/ATI - через использование библиотеки XvBA.

Кроме того, начиная с версии 1.1 пользователи смогут создавать свои собственные расширения для VLC. Разница с другими модулями VLC заключается в том, что для расширений будет использоваться язык Lua - легкий и простой язык написания скриптов. На данный момент уже реализованы следующие расширения:

  • Wikipedia: загружается информация об исполнителе и альбоме;
  • IMDb: можно прочитать краткое описание сюжета, узнать об актёрах и получить, естественно, прямую ссылку на фильм в этой базе;
  • Last.fm: загрузка полезной информации со страницы артиста на этом сайте;
  • Автоматическая загрузка текст песен;
  • Поиск и подключение субтитров в 2 нажатия мыши;
  • Показ информации о концертах исполнителя.

Также объявлены первые результаты разработки нового неофициального GUI-интерфейса Gnome-Vlc, пропагандирующего подход максимального упрощения. По заявлению разработчиков GNOME-Vlc сосредоточен только на проигрывании видео, без лишних настроек и усложнений. Дополнение: несколько дней назад проект GNOME-Vlc был переименован в GNOME Media Player, так как кроме проигрывания видео с использованием libvlc была дополнительно добавлена поддержка возможности использования xine-lib.