Обновление поддерживаемых веток PostgreSQL и новый RPM-репозиторий проекта

16.03.2010 20:42

Выпущены новые корректирующие релизы во всех поддерживаемых ветках PostgreSQL: 8.4.3, 8.3.10, 8.2.16, 8.1.20, 8.0.24 и 7.4.28. В новых версиях исправлено 47 ошибок, накопившихся за последние три месяца. Кроме того, в анонсе разработчики напоминают, что поддержка веток PosgreSQL 7.4 и 8.0 будет прекращена в июне 2010 года.

Из исправлений можно отметить:

  • В SSL-подсистему PostgreSQL добавлен код для отключения возможности выполнения операций согласования установленного SSL-соединения (renegotiation) для серверов, подверженных атаке через подстановку данных в устанавливаемое между двумя точками защищенное соединение. Для управления частотой выполнения операций согласования соединения в файл конфигурации добавлена директива "ssl_renegotiation_limit";
  • Устранена потенциальная возможность взаимной блокировки (deadlock) в процессе запуска СУБД;
  • Устранено несколько ошибок, которые могли привести к краху;
  • В GIN и GiST индексах устранены ошибки, которые могли привести к некритичной потере данных при откате операции из WAL-лога;
  • Устранены две утечки памяти;

Дополнительно, сообщается о появлении специализированного RPM-репозитория со сборками PostgreSQL для дистрибутивов Fedora, CentOS и RHEL - yum.pgrpms.org. В репозитории представлены пакеты с последними версиями веток PostgreSQL 9.0-beta, 8.4, 8.3 и 7.3.